Integrator Resources

The official home for NAI Support

Not sure where to start? Try Quick Start Guide or ask a question below!

Toggle Components with Visual Button
JavaScript Form Processing

Managed Ethernet Switch

ES2 SWITCH CONFIGURATIONS & UTILITIES

Unless otherwise documented,

Default Configuration as shipped:

  1. ES2 Port-1 is the only port which will be enabled. This allows GbE access for additional customer configuration or initialization after delivery. The RS-232 serial port is also available for console command configuration or initialization.

  2. Switch IP Address: 12.0.0.1 / Subnet Mask: 255.0.0.0

The ES2 system supports different methods of accessing the switch, namely:

  • CLI (Command Line Interface using the serial port on the ES2)

  • Telnet, SSH (similar to CLI, but physical connection is an in-band Ethernet port)

  • HTTP (HyperText Transfer Protocol)

  • SNMP (Simple Network Management Protocol, which is an industry standard method of managing Ethernet networks)

Throughout this chapter, the management tool used is referenced as a standard Microsoft Windows-based “PC” running application software (e.g. terminal emulation or internet browser software).

Configuring the Management PC’s Ethernet Port

To allow each of the above-mentioned Ethernet configuration utilities to access the ES2, the PC’s Ethernet port must be configured properly. For example, if the ES2 default IP address was set to 12.0.0.1 with a subnet mask of 255.0.0.0, the management PC must be configured to operate within the same IP subnet.

Continuing with this example, the PC must now be configured to operate within this same IP subnet.

Set the IP address of the Network Interface Card on the PC to be within the same subnet. For example, set the PC’s IP address to be 12.0.0.20.

The various configuration utilities supported by ES2 allow the user to configure, manage, and monitor the ES2 switch. Overviews of the CLI, Telnet, SSH, HTTP, and SNMP methods of connecting to the Management Port are provided in this section of the manual.

Command Line Interface (CLI) Overview

Telnet/SSH Overview

Once the PC is configured to operate on the Management network, it is now possible to connect through the Ethernet port of the ES2 switch. To open a Telnet or SSH session, you can use applications such as Tera Term or simply a DOS Command window. Once the connection is established through this window, the Telnet or SSH session provides access to the CLI interface.

Note
The default ES2 login is root with password admin123.

SNMP Overview

The Simple Network Management Protocol (SNMP) has proven to be a useful protocol for network management. Network administrators are well served by learning about SNMP and using this protocol to monitor and manage their networks. Although the SNMP standard is somewhat complex, entailing specific knowledge of MIB objects as well as requiring a large amount of configuration related to both SNMP agents and management software, the use of SNMP has been proven to be a cost-effective method of achieving a managed system.

There are many different software packages that can browse and manage MIB objects through the SNMP interface, and it is outside the scope of this manual to review them all.

Saving Configurations on Flash

Once the ES2 has been configured, it is possible to save the final configuration, and upon each subsequent reboot or power cycle the ES2 will initialize to this configuration.

These configuration settings may be saved though the Management Port interface and may be saved as many times as you choose.

Saving Configurations with CLI

Using the CLI interface, whether it is via the serial port or Telnet, the user must be logged on as administrator. As shown in “Telnet/SSH Overview", log in as username root and password admin123.

Assuming that the ES2 is completely configured and you would now like to save this configuration, from the command line type the following:

ES2# write startup-config

or

ES2# copy running-config startup-config

This utility saves the configuration onto the on-board Flash. Now every time the ES2 system is restarted, this base configuration will be re-invoked on the ES2.

To reset to factory defaults:

ES2# erase startup-config

Then power cycle the ES2 or reset the ES2 by typing the following:

ES2# reload

Command Line Interface

The CLI (Command Line Interface) is used to configure the ISS from a console attached to the serial port of the switch or from a remote terminal using TELNET or SSH.

The following table lists the generic CLI command modes.

Command Line Interface

Command Mode

Access Method

Prompt

Exit method

User EXEC

This is the initial mode to start a session.

es2>

The logout method is used.

Privileged EXEC

The User EXEC mode command enable is used to enter the Privileged EXEC mode.

es2#

To return from the Privileged EXEC mode to User EXEC mode, the disable command is used.

Global Configuration

The Privileged EXEC mode command configure terminal is used to enter the Global Configuration mode

es2(config)#

To exit to the Privileged EXEC mode, the end command is used.

Interface Configuration

The Global Configuration mode command interface <interfacetype> <interfaceid> is used to enter the Interface configuration mode.

es2(config-if)#

To exit to the Global Configuration mode, the exit command is used and to exit to the Privileged EXEC mode, the end command is used.

Config-VLAN

The Global Configuration mode command vlan vlanid is used to enter the Config-VLAN mode

es2(configvlan)#

To exit to the Global Configuration mode, the exit command is used and to exit to the Privileged EXEC mode, the end command is used.

Starting ISS

At the ISS login prompt that is displayed, use the user name root and password admin123 to access the CLI shell.

ISS login: root

Password: ********

es2#

Configuring the Switch

The basic configuration of the switch involves configuring IP address, VLAN, and so on. All commands and parameters can be abbreviated to their shortest unambiguous length. On the command line, the TAB key may be used to display available command options and autocomplete commands. The 'help' command displays a list of commands.

The ES2 comes up with a VLAN configured, by default. This VLAN is called the default VLAN (VLAN ID = 1). All ports in the switch are members of the default VLAN. Port 1 (g 0/3) is enabled by default.

The ports are configured and referenced as <interface-type>[space]<slot number>/<port number>

<interface-type> is either “gigabitethernet” or “extreme-ethernet” and can be abbreviated as “g” or “e”.

<slot number> is 0.

<port number> is 3 to 18 for 1 Gb ports and 1 to 4 for 10Gb ports.

External port # Internal nomenclature

1

(g)igabitethernet 0/3

2

g 0/4

3

g 0/5

4

g 0/6

5

g 0/7

6

g 0/8

7

g 0/9

8

g 0/10

9

g 0/11

10

g 0/12

11

g 0/13

12

g 0/14

13

g 0/15

14

g 0/16

15

g 0/17

16

g 0/18

10 Gb fiber optic

1

(e)xtreme-ethernet 0/1

2

e 0/2

3

e 0/3

4

e 0/4

Examples

The interfaces in the switch except for port 1 are disabled by default. Hence, enable all the interfaces that are to be used. This is done using the no shutdown command.

To enable all 16 gigabit ethernet ports

es2# c t
es2(config)# interface range g 0/3-18
es2(config-if-range)# no shutdown
es2(config-if-range)# exit
es2(config)# exit
es2#

To disable port 2

es2# c t
es2(config)# interf g 0/4
es2(config-if)# shutdown
es2(config-if)# end
es2#

To enable port 2

es2# c t
es2(config)# interf g 0/4
es2(config-if)# no shut
es2(config-if)# end
es2#

To enable all 4 10 Gb fiber ports

es2# c t
es2(config)# interf range e 0/1-4
es2(config-if-range)# no shut
es2(config-if-range)# end
es2#

To disable 10 Gb port 3:

es2# c t
es2(config)# interf e 0/3
es2(config-if-range)# shut
es2(config-if-range)# end
es2#

To enable 10 Gb port 3:

es2# c t
es2(config)# interf e 0/3
es2(config-if-range)# no shut
es2(config-if-range)# end
es2#

The show interfaces command displays the complete information of all available interfaces.

es2# show interfaces

A new VLAN can be configured using the following command. This command configures a new VLAN with VLAN ID 2.

es2# c t
es2(config)# vlan 2

Configure Port1, Port2, and Port3 as member ports. Port 1 is specified as an untagged port and Port 2 and Port 3 are set as tagged ports for VLAN 2.

es2(config-vlan)# ports gig 0/3-5 untagged gig 0/3
es2(config-vlan)# exit

However, any untagged packets (packets sent from a PC/host) on any of the ports will be classified only to VLAN1. To ensure that untagged packets get classified onto a specific VLAN, it is required to change the port VLAN ID.

This is done using the following commands:

es2(config)# interface gig 0/3
es2(config-if)# switchport pvid 2
es2(config-if)# exit
es2(config)# exit

Now untagged packets received on Port 1 will get classified to VLAN2. The ip address command can be used to configure the IP address of a VLAN interface.

es2# configure terminal
es2(config)# interface vlan 2
es2(config-if)# ip address 30.0.0.1 255.0.0.0

The interface status must be up for the IP interface to be reachable from an external host/PC.

es2(config-if)# no shutdown
es2(config-if)# exit
es2#

The show ip interface vlan <vlan-identifier> configuration can be used to check whether the configuration is successful or not.

es2# show ip interface vlan 2

Saving and Restoring Configuration

The configuration made by the user can be saved in the Flash and can be restored when the switch is started.

es2# write startup-config

The configurations saved using write startup config command will not update the configurations in issnvram.txt (that is, it will not change the factory default settings). If the factory default settings need to be changed, administrator should explicitly modify it through default ip address command.

Configuring the Default IP Address

Configuring the Default IP Address is a three-step procedure that will result in the IP address to be written to the NVRAM and configuration and this will be used as the IP address of the default interface when the switch is restarted.

  1. Execute the default ip address command.

  2. Configure the ip address for vlan 1.

  3. Save the configuration.

Detailed Steps:

1) Execute the following commands to configure the Default IP Address. Enter the Global Configuration mode.

es2# configure terminal

Configure the default IP address and subnet mask as 12.0.0.100 and 255.255.0.0, respectively.

es2(config)# default ip address 12.0.0.100 subnet-mask 255.255.0.0

Exit from the Global Configuration mode.

es2(config)# end

2) View the default IP address and subnet mask by executing the following command

es2# show nvram
Default IP Address : 12.0.0.1
Default Subnet Mask : 255.0.0.0
Default IP Address Config Mode : Manual
Default IP Address Allocation Protocol : DHCP
Switch Base MAC Address : 00:16:c6:ff:00:01
Default Interface Name : Gi0/3
Default RM Interface Name : NONE
Config Restore Option : Restore
Config Save Option : Startup save
Auto Save : Disable
Incremental Save : Disable
Roll Back : Enable
Config Save IP Address : 0.0.0.0
Config Save Filename : iss.conf
Config Restore Filename : iss.conf
PIM Mode : Sparse Mode
IGS Forwarding Mode : MAC based
Cli Serial Console : Yes
SNMP EngineID : 80.00.08.1c.04.46.53

Proceed to section “Configuring IP address for an Interface” and set the same IP address and subnet mask for VLAN 1 (default VLAN). The switch will have this IP address and subnet mask after the switch restart only if the allocation method is manual.

Setting the Default IP Allocation Mode for the Switch

Setting the default IP allocation mode for the Switch configures the mode by which the default interface acquires its IP address. The default IP allocation mode for a switch can be manual or dynamic. The default value is manual.

1) Execute the following commands to change the default IP allocation mode of the default VLAN.

Enter the Global Configuration mode.

es2# configure terminal

Configure the default mode to dynamic.

es2(config)# default mode dynamic

Exit from the Global Configuration mode.

es2(config)# end

2) View the default mode by executing the following command.

es2# show nvram
Default IP Address : 12.0.0.1
Default Subnet Mask : 255.0.0.0
Default IP Address Config Mode : Dynamic
Default IP Address Allocation Protocol : DHCP
Switch Base MAC Address : 00:01:02:03:04:01
Default Interface Name : Gi0/1
Config Restore Option : No restore
Config Save Option : No save
Auto Save : Enable
Incremental Save : Disable
Roll Back : Enable
Config Save IP Address : 0.0.0.0
Config Save Filename : iss.conf
Config Restore Filename : iss.conf
PIM Mode : Sparse Mode
IGS Forwarding Mode : MAC based
Cli Serial Console : Yes
SNMP EngineID : 80.00.08.1c.04.46.53

ISS uses the dynamic address allocation protocols - BOOTP or DHCP or RARP - to acquire the IP for management VLAN during switch restart.

Configuring Default IP Address Allocation Protocol

Configuring the default IP address allocation protocol configures the protocol by which the default interface dynamically acquires its IP address.

1) Execute the following commands to configure the default dynamic address allocation protocol.

Enter the Global Configuration mode.

es2# configure terminal

Configure the default allocation protocol.

es2(config)# default ip address allocation protocol dhcp

Exit from the Global Configuration mode.

es2(config)# end

2) View the default IP Address Allocation Protocol by executing the following command

es2# show nvram
Default IP Address : 12.0.0.100
Default Subnet Mask : 255.255.0.0
Default IP Address Config Mode : Dynamic
Default IP Address Allocation Protocol : DHCP
Switch Base MAC Address : 00:01:02:03:04:01
Default Interface Name : Gi0/1
Config Restore Option : No restore
Config Save Option : No save
Auto Save : Enable
Incremental Save : Disable
Roll Back : Enable
Config Save IP Address : 0.0.0.0
Config Save Filename : iss.conf
Config Restore Filename : iss.conf
PIM Mode : Sparse Mode
IGS Forwarding Mode : MAC based
Cli Serial Console : Yes
SNMP EngineID : 80.00.08.1c.04.46.53

Configuring IP Address for an Interface

Configuring IP address for an Interface configures the IP address which will be used for sending and receiving the packets.

1) Execute the following commands to configure an IP address for a VLAN interface. Enter the Global Configuration mode.

es2# configure terminal

Enter the Interface Configuration mode.

es2(config)# interface vlan 1

Shut down the VLAN interface.

es2(config-if)# shutdown

Configure the IP address and subnet mask.

es2(config-if)# ip address 12.0.0.100 255.0.0.0

Bring up the VLAN interface.

es2(config-if)# no shutdown

Exit from the Interface Configuration mode.

es2(config)# end

Configuring the IP address for an Interface requires the interface to be shutdown prior to the configuration.

2) View the configured interface IP address by executing the following show command.

es2# show ip interface
Vlan1 is up, line protocol is up
Internet Address is 12.0.0.100/8
Broadcast Address 10.255.255.255

3) Save the configuration

es2# wr st

Configuring an Interface to Acquire Dynamic IP

An interface can be configured to acquire the dynamic IP address either from DHCP or from RARP. The default value is DHCP.

1) Execute the following commands to acquire dynamic IP for VLAN 1 through DHCP.

Enter the Global Configuration mode.

es2# configure terminal

Enter the Interface Configuration mode.

es2(config)# interface vlan 1

Configure the VLAN interface to dynamically acquire an IP address through the Dynamic Host Configuration Protocol

es2(config-if)# ip address dhcp

Exit from configuration mode.

es2(config)# end

2) View the configured IP address by executing the following show command.

es2# show ip interface
Vlan1 is up, line protocol is up
Internet Address is 12.0.0.1/8
Broadcast Address 10.255.255.255
IP address allocation method is dynamic
IP address allocation protocol is dhcp

A DHCP server must exist in the network to allocate dynamic IP through DHCP mechanism.

Industry Standard CLI (Command Line Interface)

CLI commands are focused on performing specific operations. In order to provide a consistent, composable user experience, the CLI commands of the ES2 protocols and IP implementation solutions adhere to the Industry Standard CLI syntax.

The following table provide a listing and identification of which CLI commands are supported.

NAI Reference ONLY

Package Details (NAI Reference ONLY)

NAI

CLI Volume No:

Chapter No:

Chapter Title

Work Group

Enterprise

Metro

Metro_E

ES2 Support

1

1

Introduction

NA

NA

NA

NA

2

Command Line Interface

NA

NA

NA

NA

3

System Commands

Y

Y

Y

Y

YES

4

System Features

Y

Y

Y

Y

YES

5

VCM

N

Y

Y

N

YES

6

RADIUS

Y

Y

Y

Y

YES

7

TACACS

Y

Y

Y

Y

YES

8

SSH

Y

Y

Y

Y

YES

9

SSL

Y

Y

Y

Y

YES

10

SNTP

Y

Y

Y

Y

YES

11

SNMPv3

Y

Y

Y

Y

YES

12

Syslog

Y

Y

Y

Y

YES

13

TCP

Y

Y

Y

Y

YES

14

UDP

Y

Y

Y

N

YES

15

PoE

Y

Y

Y

N

NO

16

L2 DHCP Snooping

Y

Y

Y

Y

NO

17

IPDB

Y

Y

Y

Y

YES

2

18

STP

Y

Y

Y

Y

YES

19

LA

Y

Y

Y

Y

YES

20

LLDP

Y

Y

Y

Y

YES

21

PNAC

Y

Y

Y

Y

YES

22

MRP

Y

Y

Y

Y

NO

23

ELMI

N

N

Y

Y

NO

24

ELPS

N

N

Y

Y

NO

25

ERPS

N

N

Y

Y

NO

26

PBB

N

N

Y

Y

NO

27

PBB-TE

N

N

Y

Y

NO

3

28

VLAN

Y

Y

Y

Y

YES

29

ECFM

N

N

Y

Y

NO

30

IPSecv6

Y

Y

Y

Y

NO

31

VRRP

N

Y

N

Y

NO

4

32

IP

Y

Y

Y

Y

YES

33

IPV6

Y

Y

Y

Y

YES

34

OSPF

N

Y

N

Y

YES

35

OSPFv3

N

Y

N

Y

YES

36

RRD

N

Y

N

Y

YES

37

RRD6

N

Y

N

Y

YES

38

MPLS - General Commands

N

Y

Y

Y

NO

MPLS - LDP Signaling

N

Y

Y

Y

NO

MPLS - RSVP Signaling

N

Y

Y

Y

NO

MPLS - OAM

N

N

Y

Y

NO

MPLS - LSPping

N

N

Y

Y

NO

MPLS - L3VPN

N

N

Y

Y

NO

39

BFD

N

N

Y

Y

NO

40

Route Map

N

Y

N

Y

YES

41

NAT

N

Y

N

Y

YES

5

42

DHCP

Y

Y

Y

Y

YES

43

DHCPv6

Y

Y

Y

Y

YES

44

RIP

N

Y

N

Y

YES

45

RIPv6

N

Y

N

Y

YES

46

BGP

N

Y

N

Y

NO

47

ISIS

N

Y

N

Y

NO

6

48

IGMP Snooping

Y

Y

Y

Y

YES

49

MLD Snooping

Y

Y

Y

Y

YES

50

IGMP

N

Y

Y

N

YES

51

IGMP Proxy

Y

Y

Y

Y

YES

52

PIM

N

Y

N

Y

YES

53

PIMV6

N

Y

N

Y

YES

54

DVMRP

N

Y

N

Y

NO

55

IPv4 Multicasting

N

Y

N

Y

YES

56

TAC

Y

N

N

Y

YES

57

RMON

Y

Y

Y

Y

YES

58

RMON2

Y

Y

Y

Y

NO

59

DSMON

Y

Y

Y

Y

NO

60

EOAM

Y

Y

Y

Y

YES

61

FM

Y

Y

Y

Y

YES

62

RM

N

Y

Y

Y

NO

63

PTP

Y

Y

Y

Y

NO

64

Layer 4 Switching

Y

Y

Y

Y

YES

7

65

DCB

Y

Y

N

Y

NO

66

MLDv2

N

Y

N

Y

YES

67

MSDP

N

Y

N

Y

NO

68

MSDP6

N

Y

N

Y

NO

69

FIREWALL

N

Y

N

Y

YES

70

VPN

N

Y

Y

Y

YES

71

DNS

Y

Y

Y

Y

YES

72

Security

N

Y

N

Y

YES

73

Security - FIPS

Y

Y

Y

N

YES

74

TLM

N

Y

Y

Y

NO

75

OSPF-TE

N

Y

Y

Y

NO

76

TRILL

N

Y

N

Y

NO

77

SyncE

Y

Y

Y

Y

NO

78

MEF

N

N

Y

Y

NO

79

OFCL

N

N

N

Y

NO

80

Clock IWF

Y

Y

Y

Y

YES

81

PPP_Draft

N

Y

N

Y

NO

82

VXLAN

N

N

N

Y

NO

83

HEART BEAT

N

N

N

Y

NO

84

ICCH

Y

Y

Y

Y

YES

8

85

BCM

Y

Y

Y

Y

YES

86

Marvell XCAT

Y

Y

Y

Y

NO

87

Fulcrum_Draft

NA

NA

NA

NA

(Reference ONLY)

88

Marvell 6095_Draft

NA

NA

NA

NA

(Reference ONLY)

89

Wintegra_Draft

NA

NA

NA

NA

(Reference ONLY)

90

Dx-167

NA

NA

NA

NA

(Reference ONLY)

91

Other Targets_Draft

NA

NA

NA

NA

(Reference ONLY)

92

QoSX_Draft

NA

NA

NA

NA

(Reference ONLY)

93

Vitesse

NA

NA

NA

NA

(Reference ONLY)

Revision History

Module Manual - ES2 Revision History

Revision

Revision Date

Description

C

2021-11-03

C08845, Initial Release

C1

2022-09-30

ECO C09691, Pg.12, added 'es2# c t'. Pg.12, changed 'gigbabitethernet 0/1' to 'es2(config-vlan)# ports gig 0/3-5 untagged gig 0/3'. Pg.12, changed 'interface gigabitethernet 0/1' to 'gig 0/3'.

NAI Cares

North Atlantic Industries (NAI) is a leading independent supplier of Embedded I/O Boards, Single Board Computers, Rugged Power Supplies, Embedded Systems and Motion Simulation and Measurement Instruments for the Military, Aerospace and Industrial Industries. We accelerate our clients’ time-to-mission with a unique approach based on a Configurable Open Systems Architecture™ (COSA®) that delivers the best of both worlds: custom solutions from standard COTS components.

We have built a reputation by listening to our customers, understanding their needs, and designing, testing and delivering board and system-level products for their most demanding air, land and sea requirements. If you have any applications or questions regarding the use of our products, please contact us for an expedient solution.

Please visit us at: www.naii.com or select one of the following for immediate assistance:

Application Notes

Calibration and Repairs

Call Us

(631) 567-1100

Help Bot

X